Linux&Windows: Windows7 non si avvia in dual boot con Slackware (Lilo Errors…)

Ho appena installato la Slackware 13.37 dal DVD, ovviamente una FULL INSTALLATION…tutto ha funzionato a meraviglia sul mio nuovo HP Pavillion dv6 6099el e ovviamente ho fatto i salti di gioia perche’ non mi era mai capitato con nessuna distro….
Solo 2 piccoli problemi, dico piccoli perche’ si risolvono in 2 minuti ma in realta’ sono molto fastidiosi:

  1. WiFi Broadcom modello BCM4313: non riconosceva la scheda, e’ bastato scaricare i sorgenti del driver dal sito del produttore Broadcom e seguire le istruzioni per la compilazione. Nel dvd slackware, se non ricordo male nella cartella extra c’e’ il pacchetto per WICD, un programmino molto efficiente (quando lo usai anni fa non funzionava per nulla) che permette di gestire le connessioni wifi e wired, funziona a meraviglia, d’ora in po niente shell per la wifi .
    RICORDARE di lasciare impostato il tipo di driver come WEXT, lo dico perche’ nel README dei sorgenti del firmware per la wifi parla di altri driver, comunque cosi’ funziona, perche’ cambiare…in ogni caso fare tutto come dice nel README per la compialzione del firmware…E ovviamente leggere il txt del pacchetto Slackware per WICD, dove tra le altre cose, dice di non usare il file di configurazione /etc/rc.d/rc.inet1.conf per la wifi, basta commentare le righe…
  2. Boot Windows 7 errror e questo pure una rottura, ma in 1 minuto con la lettura di alcuni post si e’ risolto. In pratica, per quel che ne ho capito, adesso Windows 7 utilizza una sorta di partizione di boot, infatti se usate un software per il partizionamento, tipo quello nativo di windows dentro Strumenti di Amministrazione-Gestione Disco (spero di ricordare bene ), oppure da Linux (Slackware ovviamente) usando cfdisk si vedra’ che la partizione in cui e’ istallato windows non e’ bootable come succedeva prima con windows xp, ma c’e’ almeno un altra partizione nascosta o comunque non esplorabile da windows, che invece e’ bootable.
    Cosa succede, al riavvio selezionando windows 7, questo non parte, ci viene restituito un errore e il consiglio di usare i dvd di installazione per ripristinare la situazione. Io non l’ho fatto per paura di dover reinstallare tutto di nuovo (che palle ). Ho risolto cosi’, leggendo un po’ da questo thread e forse qualcos’altro…in pratica mi e’ venuta in mente questa partizione di boot nascosta ed ho modificato il mio bel file /etc/lilo.con nella sezione per windows in questo modo:
    # Windows bootable partition config begins
    other = /dev/sda1
    label = Windows
    table = /dev/sda
    # Windows bootable partition config ends

    tenete conto pero’ che la mia partizione di Windows 7 e’ in /dev/sda2 e non in /dev/sda1 dove invece risiede la partizione nascosta bootable.
    Facendo cosi’ anche windows parte senza problemi, e soprattutto senza rischiare di dover reinstallare tutto

Dimenticavo….ho usato il software slackyd, scritto da un frequentatore di slacky.eu, per scaricare alcuni pacchetti aggiornati e soprattuto Skype, che ha funzionato al primo colpo sia per il video che per l’audio, FANTASTICO!!!! col mio vecchio portatile era una battaglia persa…ma usavo altre distro…

Insomma, meno male che sono tornato a Slackware, la miglior distro di sempre, anche se forse occorre essere un pelino piu’ esperti, ma non tanto…

Leave a Reply